open all | close all

Generated by CHM Decoder

Need you translate this to other language?
Get CHM Editor Now!


Учимся программировать в среде Scratch

Учимся программировать
в среде Scratch

Главная

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Придумай - Запрограммируй - Поделись

По материалам Евгения Патаракина

Щербакова Ольга Борисовна
пгт Яя


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

движение внешность звук перо

Числа
Кирпичики чисел
(зеленый ящик)

Кирпичики чисел и датчики - все это бойцы невидимого фронта. А кирпичики чисел
можно использовать только внутри строительных блоков. Сами по себе как строительный
материал эти кирпичики использовать нельзя. Они возвращают результат. Как правило,
все арифметические и логические блоки используются вместе с блоками управления.

Команда | Назначение
() + () | операция сложения
() – () | вычитание
() * () | умножение
() / () | деление
() > () | Сравнение больше, равно, меньше. Например: ((5) * (5)) < ((4) * (10))
Выдать случайное от () до () | Возвращает число в интервале от () и до (). Например: Установить направление(Выдать случайное от (-180) до (180
Логические операторы. Эти блоки содержат входные окошки, куда вставляются кирпичики сравнений.
<> и <> <> или <> Не <> | Например: () и ()
Функция от () | Перечень возможных функций показан на рисунке после этой таблицы

Возможные вычисляемые функции:


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Знакомимся с интерфейсом программы

Наш первый сценарий Что где лежит

Чтобы начать работать в среде Scratch, достаточно ткнуть указателем мышки в мордочку симпатичному зверьку на экране – Scratch и запустится. Перед нами экран программы Scratch.

Справа большая область, на которой находится главный герой программы. Здесь происходят события, сюда можно добавлять новые программируемые объекты. Белый фон может меняться на другие. И героям и фону, на котором они действуют, можно давать команды. Команды разложены как кирпичики в ящичках в левой верхней части экрана. В данный момент открыт синий ящик, и мы видим команды движения, которые в этом ящике лежат. Чтобы выполнить команду или собрать из нескольких команд сценарий – скрипт, нужно положить команду в центральную серую область.
Справа - область экрана или мира, где существует кошка и все другие существа, которых мы можем в мир призвать.

Зеленый флажок служит в качестве сигнала, который воспринимают и на который реагируют все присутствующие в данном проекте объекты.

Красная кнопка Stop - останавливает движения и действия всех объектов.

Мы можем взять любой объект и осуществить над ним действия:
• видоизменить его внешний вид при помощи фиолетовых команд-кирпичиков внешнего вида;
• переместить его при помощи синих команд кирпичиков перемещения;
• поместить команды перемещения и видоизменения внутрь оранжевых блоков управления;
• добавить к управляющим блокам фиолетовые кирпичики звуков;
• и т.д.

И наш исполнитель 10 раз [Округлился, повернулся, искривился, прошел 10 шагов],
а после этого хлопнул в ладоши.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

Движение
Синий ящик

В синем ящике сложены строительные блоки, управляющие перемещением
объектов по экрану.

Кошка Скретч является прямым потомком черепашки Лого, и она наследовала многие из команд передвижения. При этом ошибку в команде сделать сложнее, поскольку
количество шагов или градусов интегрированы с самой командой. Поверхность экрана,
по которой перемещается Кошка, напоминает по своим свойствам экран, по которому
перемещалась Черепашка. Центральная точка экрана соответствует координатам X=0,
Y=0. Вправо от нулевой точки X возрастает и это область положительных значений.
Влево – область отрицательных значений.

Сложнее всего использовать блоки, которые не являются командами, а возвращают
значения – положение x, y и направление. Простой пример:
Мы хотим, чтобы котенок последовательно переходил из нижнего правого угла в
левый верхний угол.

Команда | Назначение
Идти | пройти вперед указанное число шагов. Например: Идти(10) – сделать десять шагов назад Идти (-30) – сделать 30 шагов назад
Повернуться на | повернуться - стрелочка указывает по часовой или против часов стрелки выполняется поворот. Например: повернуться на 45 градусов (стрелочка указывает по или против часовой стрелки)
Повернуться в направление() | Повернуться в указанном направлении. Например: повернуться в направление(180)
Повернуться к | Повернуться в направлении другого существа или координат мышки. После команды всегда существует перечень объектов, которые в данный момент присутствуют в системе и на которые можно реагировать. В самом простом случае, когда других объектов нет, предлагается повернуться в сторону, где находится указатель мышки.
Изменить Х на() | Изменить положение по оси X на указанное число шагов. Например: Изменить X (-10) – объект смещается влево на 10 шагов
Установить x в () | Установить объект положение по оси x. Например: Установить x в (50)
Идти в x () y() | Переместиться в точку с указанными координатами Например: Идти в x(70) y(-50)
Плыть () сек в точку | Плавно переместиться в точку с указанными координатами за указанное время. На перемещение затратится время указанное в секундах. Например: Плыть(20) сек в точку x(90) y(90) Объект медленно (в течение 20 секунд) будет переползать в указанную точку.
Идти в () | Перейти в точку, где расположен указатель мыши или другая фигура.
Если край, оттолкнуться | Если попадаешь в край экрана, то отразись от него. Это очень полезно, если Вы не хотите потерять своего героя
Следующие несколько блоков нельзя использовать в качестве отдельных строительных блоков, но они могут быть вставлены внутрь строительных кирпичиков в качестве входных параметров
Положение х | Возвращает значение по оси X Например: Установить y (положение x)
Положение Y | Возвращает значение по оси y Например: Установить x (положение y)
Направление | Возвращает направление


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Знакомимся с интерфейсом программы

Наш первый сценарий Что где лежит

Познакомимся подробнее с возможностями, которые нам доступны в меню:

Верхняя часть:
Новый – Создать Новый проект
Открыть – открыть проект
Сохранить – сохранить текущий проект
Сохранить как – сохранить проект под новым именем
Публиковать! – размещение проекта в общей сетевой коллекции
Отмена – отмена последней команды.
Язык – выбор интерфейса. Изначально Скретч был написан на английском, но в
последние годы добавилось еще множество языков, которые понимают объекты Скретч.

Левая часть рабочего экрана представляет ящички, в которых лежат кирпичики для
программирования:

• Фиолетовый - Внешность - Изменение внешнего вида
• Синий - Движение - Перемещение объектов
• Лиловый – Звуки - звуки, ноты и множество инструментов
• Зеленый – Числа - Операции с числами, сравнение,
логические операторы
• Желтый – Контроль - контролирующие операторы
• Ярко-зеленый – Перо - возможность рисовать на экране
• Голубой – Сенсоры – датчики и возможность определять
направление, расстояние и т.п.
• Красный - Переменные – переменные, которые можно
передавать в скрипты и которым можно
присваивать значения от датчиков.

Центральная часть рабочего экрана Скретч.
Скрипты - область, где из элементов собираются управляющие скрипты
Костюмы, которые может надевать на себя кошка или другой герой. Мы можем добавлять костюмы из библиотек или рисовать новые.

Звуки - звуки, которые кошка может издавать.

Мы можем добавлять звуки из библиотек или сами записывать новые – в Скретч
встроена программа аудиозаписи.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

Контроль
Кирпичики контроля
(желтый ящик)

Кирпичики контроля позволяют собирать блоки команд и управлять
последовательностью исполнения скриптов. Они определяют то, при каких условиях
совершается то или иное действие. Они позволяют спрайтам передавать, принимать и
реагировать на управляющие сообщения.

Команда | Назначение
Когда щелкнуть по флажку | Запускает скрипт в ответ на щелчок по зеленому флажку. Это обычный способ запуска всей модели.
Когда нажата () клавиша | Запускает выполнение блока команд в ответ на нажатие выбранной клавиши. Позволяет передать управление на клавиатуру. Например: когда нажата стрелка вверх, повернуть вверх
Ждать () | Команда ожидания. Параметр () указывает сколько секунд следует ждать.
Всегда | Блок команд, заключенных внутрь конструкции будет выполняться постоянно.
Если <> | Условие, при выполнении которого должны выполняться команды, заключенные внутри конструкции. Если не выполняется, то никаких действий
Если <> или | Условие, при выполнении которого должны выполняться команды, заключенные внутри конструкции если. Если не выполняется, то нужно перейти к действиям внутри блока или.
Повторить() | Повторение. Параметр указывает, сколько раз нужно повторить блоки команд, заключенные внутри блока повторить() Например, повторить 20 (идти 50 повернуть 45)
Передать () | Передать сообщение. Переданное сообщение может запускать активность другого исполнителя. Работает в сочетании с командой «Когда я получил ()»
Когда получил () | Запускает выполнение блока команд в ответ на полученное сообщение. Работает в сочетании с «передать ()»
Всегда если () | Выполняется до тех пор, пока условие () верно
Ждать до () | Ждать, пока не выполнится условие
Остановить скрипт | Остановить выполнение программы для данного исполнителя
Остановить всё | Остановить выполнение всех программ


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Первые шаги

Пример № 1 Мультипликация

Что нам потребуется для мультипликации:
· Костюм кошки cat2 из библиотеки Animals
· Графический редактор Scratch
· Кирпичики из фиолетового ящика внешности
· Переменные, которые создадим в ящике «Переменные»
Мы берем костюм кошки из библиотеки, переходим в режим костюмы и копируем костюм cat2. У нас появляется костюм cat3 – точная копия cat2. Мы создадим две версии костюма кошки, и в одной версии кошка будет с голубыми линзами, а в другой с черными.
Чтобы было заметнее, мы у голубоглазой кошки еще и хвостик оторвем. Эту копию мы редактируем в графическом редакторе Скретч. Кисточкой подрисовываем кошке синие глазки, ластиком отрываем хвостик.

Теперь попробуем управлять внешним видом кошки и сделаем это поведение
неожиданным для себя. Для этого воспользуемся оранжевым ящиком переменных.
Ящик с переменными изначально пуст. Значения в этом ящике появляются только в результате наших действий. Мы создадим новую переменную с именем cat-name.

Обратите внимание, что при создании переменной программа спрашивает нас, хотим ли мы, чтобы эта переменная была глобальной – доступной для всех объектов, или эта переменная будет действовать только для данного объекта. В этом случае другие объекты ничего об этой переменной знать не будут.
После того как переменная создана, мы можем со значением этой переменной
совершать действия. Мы можем присваивать переменной любые числовые значения и менять ее значения на числовые значения (увеличивать или уменьшать)
Присвоим переменной значение, которое выдаст датчик случайных чисел от одного до двух. Иногда этот датчик будет выдавать число 1, иногда 2.

На нашем рисунке кошка в ответ на запуск программы говорит «0», но в среде Scratch она с равной вероятность говорит «0» и «1».Дальше мы поставим управляющие кирпичики блока из желтого ящика. Главное в этом примере – блок выбора «Если или»
· Если значение переменной = 1, то кошка надевает голубые линзы и прячет свой хвост.
· Если значение переменной = 2, то кошка надевает черные линзы.

Теперь у нас на экране кошка мигает линзами разного цвета и поджимает хвостик.
Как может быть улучшена программа?
· Можно добавить из фиолетового ящика графические эффекты и кошка будет
становить толще или искривляться.
· Можно добавить из синего ящика команду движения и кошка будет не только менять внешний вид, но и ходить по экрану.

Мы используем готовую кошку в следующем примере, где ей предстоит гоняться за мышкой.

| Пример 1 | Пример 2 | Пример 3 | Пример 4 | Пример 5 | Пример 6 | Пример 7 | Пример 8 | Пример 9 | Пример 10 |


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

движение внешность звук перо

Переменные
(оранжевый ящик)

В оранжевой ящике изначально ничего не лежит, кроме предложения «создать
переменную». Мы сами создаем кирпичики, которые планируем использовать в своих
сценариях. Если мы щелкаем по кнопке «создать переменную», то Скретч предлагает
определить имя и свойства новой переменной. Переменные могут быть глобальными и
локальными.

Глобальные переменные действую для всех объектов внутри данного проекта.
Локальные переменные действуют только для данного объекта. Например, мы хотим
несколько раз сыграть несколько нот, постепенно убыстряя темп игры. Мы создаем две
локальные переменные – «nota» и «temp»
Temp – определяет время звучания и увеличивая значение этой переменной мы
ускоряем скорость игры.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

движение внешность звук перо

Перо
Команды рисования
(темно-зеленый ящик)

В зеленом ящике собраны команды, которые позволяют управлять пером или карандашом, которым могут рисовать наши объекты. Как и черепашка Лого, все объекты Скретч могут рисовать и оставлять на экране свои отпечатки.

Мы можем менять цвета и размер карандаша, поднимать и опускать карандаш. В результате выполнения сценария на экране рисуются разноцветные геометрические фигуры.

Команда | Назначение
Очистить | Очистить экран от всех следов, которые на нем оставили объекты
Опустить перо | Опустить карандаш. После этой команды за движущимся объектом будет оставаться след.
Поднять перо | Поднять карандаш
Установить цвет пера() | Выбрать цвет, которым мы собираемся рисовать. Цвет можно выбрать из объектов на экране
Изменить цвет пера на () | Изменить цвет пера на указанное значение. Например: Изменить цвет пера на (50)
Изменить тень на () | Установить градиент цвета следа, который оставляет объект. 100 – белый, 0 – черный.
Печатать | Отпечатать объект на экране


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Знакомимся с интерфейсом программы

Наш первый сценарий Что где лежит

На рисунке показано, как мы положили 2 команды из синего ящика в центральную часть и слепили из них общий блок. Команды легко соединяются между собой – как кирпичики Лего. Если мы теперь щелкнем по блоку из двух кирпичиков, то котенок выполнит 2 команды сценария: Иди 10 шагов, поверни вправо на 15 градусов.

Цифры 10 и 15 уже были написаны внутри кирпичиков, но мы можем их изменять. К двум командам из синего ящика мы добавили еще блок из зеленого ящика с цифрами. Этот блок позволяет получить случайное число в заданном интервале. Например, кошка может сделать какое-то число шагов в интервале от 1 до 10 и повернуть против часовой стрелки на какое-то число градусов.

Теперь мы добавим к командам движения из синего ящика парочку команд управления из желтого ящика. В жёлтом ящике лежат команды не очень похожие на остальные кирпичики. Большинство из них устроены так, что в них можно запихивать другие кирпичики и организовывать их циклическое выполнение. Мы сразу возьмем блок всегда и запихаем в него наши синие кирпичики движения.

Сверху прикрепим блок запуска сценария по зеленому флажку и наш первый скрипт готов.
Теперь наш котенок будет вечно вертеться.

Мы можем сохранить результаты своей работы в отдельный проект. Для этого нужно щелкнуть по кнопке – «Сохранить» и записать название своего проекта. К сохраненному проекту всегда можно вернуться и продолжить над ним работу.

Продолжим хождение котенка по экрану и зададим простое и полезное условие: если коснулся края рабочего поля, то не убегай, а оттолкнись и измени направление. Теперь наш котенок ходит из стороны в сторону. Только почему-то так получилось, что когда он идет направо, то все хорошо, а когда налево, то идет вверх ногами.

Попробуем помочь котенку всегда двигаться вверх головой. Для этого нам нужно будет добавить еще один образ или костюм, который может надевать котенок. Сначала делаем операцию «Копировать», а затем в режиме редактирования переворачиваем котенка вверх головой.

В результате вертикального отражения в графическом редакторе мы получаем два
образа котенка:

Теперь напишем условия поведения котенка:
• Если идем налево, то надеваем костюм № 3
• Если идем направо, то надеваем костюм № 1

Можем написать другой вариант, при котором будет проверять не свое направление, а свое положение на экране.
• Если близок к правому краю, надевает костюм № 3 и устанавливает направление -90.
• А если близок к левому краю, то надевает костюм № 1 и устанавливает направление 90.

Что где лежит


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Первые шаги

Пример № 2
Взаимодействие объектов -кошка убегает от мышки

Мы хотим собрать мультфильм, в котором кошка будет преследовать мышку.
Что нам потребуется для мультипликации:
· Кошка, которую мы уже сделали в предыдущем примере
· Мышка из библиотеки Animals
· Кирпичики обмена сообщениями из рыжего желтого ящика
· Датчики из голубого ящика
Действия кошки из предыдущего примера мы несколько видоизменим.
Во-первых, она будет перемещаться не случайно, а в направлении мышки.
Во-вторых, мы добавим условие завершения работы всей модели. Если кошка коснулась мышки, то она передает ей сообщения «Я тебя съем» и заканчивает выполнение всех программ. Новым в этом примере будет создание нового сообщения:

По созданному сценарию кошка поворачивается в направлении к мышке, двигается к ней и успешно ее ловит.

Теперь мы хотим усложнить кошке задачу и научить мышку убегать от кошки.
Во-первых, пусть кошка в начале игры появляется в случайном месте экрана. Для этого мы используем команды установить x и установить y и передаем им случайные значения внутри рабочего экрана.

Во-вторых мы научим кошку исчезать, если кошка ее поймала:
Когда я получу сообщение «Я тебя съем» - спрятаться.
В третьих, мы научим мышку убегать от кошки.
Для этого мы используем для датчика. Мышка будет спокойно сидеть на месте, пока кошка не подойдет к ней на расстояние 90 шагов. Как только это случиться, мышка повернется в ту же сторону, что и кошка, несколько отклонится от этого направления и перебежит в новую точку.

В результате мы получили свою первую игровую модель, с которой можно экспериментировать.
Как может быть улучшена данная программа?
· Мы можем подобрать значения угла поворота, при котором мышка никогда не попадется в лапы кошке.
· Мы можем поместить мышку и кошку в среду, где им придется решать дополнительные задачи – обходить препятствия, реагировать на цвета и т.д.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Первые шаги

Пример № 5
Поиграем со случайными надписями на экране

Мы продолжим рисовать буквами на экране и создадим безумного буквописателя, который будет заполнять стену буквами.
Что нам потребуется для создания такого писателя?
· Две уже знакомые команды из зеленого ящика: очистить и печатать.
· Команды из фиолетового ящика: установить размер и следующий костюм.
· Команды из оранжевого ящика: всегда и повторить.
· Случайное значение из ящика чисел.
Главная хитрость проекта состоит в получении случайной буквы, которая будет отпечатываться на стене. Для получения этой буквы мы пользуемся конструкцией:
Поменяй костюм случайное число раз от 1 до 40

В результате наш писатель успешно справляется с поставленной задачей и бодро разукрашивает стенку загадочными словами:

Как может быть улучшен проект?
Развитие проекта может идти в сторону написания более осмысленных фраз.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Первые шаги

Пример № 6
Модель битвы драконов и демонов

От простого проекта, в котором кошка меняла цвет линз мы перейдем к проекту со множеством действующих персонажей. Мы еще в самом начале говорили, что Скретч это мультимедийная среда, но ни разу еще не показали этого. Теперь время пришло. Нам понадобятся знакомые конструкции, и в начале мы будем иметь дело только с одним объектом. Этот объект может надевать на себя два разных костюма – дракона и демона:

По щелчку зеленого флажка наш герой занимает случайное положение на экране и надевает на себя одну из масок – дракона или демона. Маска зависит от значения переменной (как это уже было с кошкой).

Теперь мы разрешим нашему герою перемещаться по экрану: герой меняет костюмы, проходит 10 шагов, поворачивается в случайном направлении и не покидает пределов экрана. Если он родился в костюме демона, то все эти действия он и совершает демоном. Если он родился драконом, то он ведет себя как дракон.

Теперь мы введем неожиданное предположение, что наш герой может встретить игрока другой команды. Например, зеленому дракону на пути может встретиться красный демон и он под воздействием этой встречи с красным может превратиться в демона.

Или наоборот, красному демону может встретиться зеленый дракон и он может под воздействием встречи с зеленым превратиться в дракона:

Подчеркиваем, что превращение носит необязательный характер. Может превратиться или не превратиться с вероятностью 50%.
Ниже представлен фрагмент действий нашего героя, если он действует в обличии демона:

Команда на этом не заканчивается и ниже идет запись ИЛИ:
Вести себя как дракон, а если коснешься красного демона, то можешь превратиться в демона.
И теперь возникает справедливый вопрос: откуда возьмутся все эти другие демоны и драконы, которых наш герой возможно встретит? А мы их сейчас откопируем из нашего же героя. У нас есть специальная кнопка экспорта отдельного спрайта и мы потом можем взять готовый спрайт в качестве нового героя. Мы можем таких спрайтов взять множество, и все они будут между собой взаимодействовать.

На следующем рисунке представлено поле боя, на котором бьются 25 драконов и демонов. Все они – копии этого маленького спрайта.

Это достаточно сложный пример, в котором показаны возможности копирования и взаимодействия множества объектов внутри среды Scratch. Дальнейшее развитие модели может идти в сторону уточнения поведения драконов и демонов. Может быть, они будут переходить из одной команды в другую только встретив нескольких противников.

| Пример 1 | Пример 2 | Пример 3 | Пример 4 | Пример 5 |
| Пример 6 | Пример 7 | Пример 8 | Пример 9 | Пример 10 |


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Первые шаги

Пример № 9
Сказка про репку

В этом проекте мы объединяем обмен сообщениями между группами агентов и сохранение текущих положений и направлений в переменных.

От классического варианта сказки наш проект отличается еще тем, что репка по-прежнему одна, но вытаскивать ее пришли 2 дедки. Каждый из дедок позвал на выручку по 2 бабки, каждая бабка позвала по паре Жучек, каждая Жучка прихватила пару кошек и каждая кошка прихватила по паре летучих мышек. Внучек в программе нет вообще.
Выполнение программы начинается с репки, которая занимает положение на экране, устанавливает значения и посылает сообщение дедке.

Дедка получает сообщение, идет в указанную точку, оставляет там свой след, посылает бабке сообщение и ждет от нее сигнала о завершения операции. Здесь очень важная конструкция: Передать «Бабка» и ждать.

По завершению операции

Каждый следующий агент повторяет и умножает действия предыдущего.
| Пример 1 | Пример 2 | Пример 3 | Пример 4 | Пример 5 |
| Пример 6 | Пример 7 | Пример 8 | Пример 9 | Пример 10 |


<
 | Учимся программировать в среде Scratch
Главная Что такое Scratch Знакомимся с интерфейсом программы Как добавить новый объект Скрипты Содержимое ящиков Первые шаги Сообщество Scratch | Первые шаги Пример № 1. Мультипликация Пример № 2. Взаимодействие объектов.Кошка убегает от мышки Пример № 3. Играем с геометрическими фигурами Пример № 4. Играем с буквами Пример № 5. Поиграем со случайными надписями на экране Пример № 6. Модель битвы драконов и демонов Пример № 7. Управление через обмен сообщениями Пример № 8. Сказка про Зайца и Лису Пример № 9. Сказка про репку Пример № 10. Scratch-квест


Учимся программировать в среде S

 | Учимся программировать в среде Scratch
Главная Введение Что можно делать и чему можно научиться со Скретчем? Создание новых объектов Управляющие программы - скрипты Содержимое ящиков Примеры программ в среде Скретч Рисуем в Скретч Сообщество Скретч | Придумай - запрограммируй - поделись
| Главная | Введение | Что можно делать и чему можно научиться со Скретчем? | Создание новых объектов | Управляющие программы - скрипты | Содержимое ящиков | Примеры программ в среде Скретч | Рисуем в Скретч | Сообщество Скретч |

Малышева Светлана Ивановна
г. Новый Уренгой


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

движение внешность звук перо

С енсоры
(Датчики)
голубой ящик

Кирпичики из голубого ящика тоже нельзя использовать в качестве строительных
блоков, но они могут использоваться как и числа и логические значения «истина» или «ложь».

Для того чтобы посмотреть на значение датчика можно попросить котенка проговорить
или продумать значение датчика. Интересно, что датчик может получать информацию не
только от объекта, с которым он связан, но и от любого объекта, существующего в нашей
системе.

Команда | Назначение
Мышка по x | возвращает значение указателя мыши по оси x
Мышка по y | возвращает значение указателя мыши по оси x
Касается цвета () | касается ли наш объект указанного цвета. Например: touching color () ? –
Касается цвет () цвета | Касаются ли указанные цвета. Возвращает «истина» или «ложь»
Мышка нажата | Нажата ли управляющая клавиша мышки? Возвращает «истина» или «ложь»
Касается () | Касается ли наш объект мышки или другого существа, касается ли наш объект цвета() соприкасается ли цвет() с цветом().Возвращает «истина» или «ложь»
Параметр () от () | Возвращается размер, положение по x или y, направление, костюм и громкость любого объекта существующего в данной модели.
Расстояние до () | Возвращает расстояние от нашего спрайта до выбранного объекта – край, мышка, другой спрайт.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

движение внешность звук перо


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Сообщество Scratch

В сети существует сообщество пользователей, которые обмениваются моделями, написанными на языке Scratch.
Адрес сообщества - http://scratch.mit.edu/

Scrtach интересен и сам по себе и тем сообществом, которое сложилось вокруг этого средства. В этом сообществе участники обмениваются и обсуждают результаты своей деятельности - конкретные объекты, программы, рисунки и т.п. В основании использования таких сообществ в образовании лежит философия конструкционизма и технология обмена идеями. Мы можем наблюдать, использовать и копировать небольшие фрагменты действий, которые ежедневно совершают в сети другие люди. В результате повторения простых операций мы можем через сеть постепенно перенимать способы деятельности людей умеющих и знающих больше нашего.

Мы можем находить в сети необходимые образцы поведения, о важности которых писал Питер Сенж «На самом деле мы все рождаемся системными мыслителями, способными воспринимать и понимать системы, с которыми мы взаимодействуем. Редкий ребенок в четыре года не понимает, что если он не приберется в своей комнате, то это сделают мама или папа. Дети в этом возрасте очень хорошо понимают паттерн взаимосвязи поведения нескольких людей, которые поддерживают чистоту в комнате, точно так же как они понимают множество других социальных систем, в которые они включены в своих семьях и в сообществах своих друзей. Они учатся, делая, а не слушая. Они узнают о том, кем являются они сами. Вместо того чтобы протестовать против взрослых, которые требуют их внимания и послушания, они сами ищут взрослых, которые могут дать им нужный совет и служить образцами для поведения. И дети находят эти образцы повсюду». (Senge P., 2000)

Сетевые сообщества, в которых общение происходит на основе и по поводу создаваемых участниками сообщества артефактов. В статье «Думать как дерево» МичРезник подробно описывал деятельность такого сообщества:

Примеры проектов создаются самими членами сообщества. Поскольку каждый созданный объект можно изучить и скопировать, каждый такой объект является образцом для всех остальных. Если ученица видит интересный объект, она всегда имеет возможность посмотреть код программы, который управляет поведением данного объекта. Она может создать новую версию поведения объекта, модифицировав код программы-образца. Коллекция проектов образцов внутри учебного сообщества постоянно видоизменяется. Эти изменения следуют интересам учеников вне всякого централизованного контроля. Видоизменения коллекции происходят так же, как это происходит в экологических системах, - коллекция адаптируется к смене интересов участников сообщества. Если члены сообщества выказывают повышенный интерес к проектам определенного типа, то и коллекция примеров приспосабливается к этим изменениям.

Например, несколько членов сообщества заинтересовались волшебством. Один ученик создал волшебную палочку, другой ученик создал класс волшебных объектов, третий ученик создал книгу заклинаний. Эта книга заклинаний была наполнена простыми программами, которые могли накладывать различные заклятия на всех людей, находящихся внутри данной виртуальной комнаты. Многие из членов сообщества сделали копии книги заклинаний, и многие добавили к ней свои собственные программы заклинаний. Кто-то даже создал заклинание, которое запускало в действие все заклинания, существующие внутри всего сообщества. Эта популярная программа была скопирована многими учениками. Один ребенок открыл магазин, в котором можно было купить самые новые версии магических объектов. Постепенно интерес к магии был утерян. Число магических объектов внутри сообщества постепенно уменьшилось, автоматически приспосабливаясь к интересам сообщества.

Сообщество носит открытый характер. Любой желающий может посмотреть все материалы. Регистрация необходима только, если нужно загрузить на сервер свой готовый проект.

Разные люди начинают использовать Scratch по-своему. Некоторым нравится объединять блоки и смотреть, что получается. Некоторые предпочитают начинать с готовых проектов, которые входят в пакет Scratch, и вносят изменения в код этих проектов.

Представьте, что каждый проект это - пирог. Такой пирожок со своим собственным рецептом, (программными блоками - маленькими кирпичиками). Все члены сообщества делятся своими пирожками и их рецептами. Это значит, что Вы можете попробовать пирожок и узнать, как испечь пирожки самому.

Нет никаких секретных рецептов, все рецепты открыты для всех. Каждый рецепт можно использовать и видоизменять. Рецепты могут служить источников вдохновения для новых идей. Вы можете есть пирожки и копировать чужие рецепты для создания своих собственных пирожков с другими составляющими. Эта свобода использования рецептов связана только двумя очень простыми требованиями или пожеланиями:
1. делитесь своими пирожками вместе с рецептами
2. отдавайте должное тем, кто вас вдохновил

Такой тип обмена внутри сообщества получил название Некоммерческая лицензия с указанием авторства — Копилефт. Пирожок сложнее кирпичика, он состоит из множества деталей и взаимодействие деталей может обеспечивать пирожку определенное поведение. Сообщество Scratch не идет дальше этих правил. Сообщество следует этим правилам, поскольку правила имеют смысл. Мы разрабатываем новые свойства сайта, которые помогают людям и делиться своими пирожками, и отдавать должное другим за их вклад. Например, Вы можете заметить, что всегда необходимо скачивать авторские блоки каждого проекта. Пожалуйста, всегда упоминайте людей, чьи проекты использованы в ваших собственных произведениях.

Что можно делать в сообществе Scratch:
- Просматривать готовые проекты прямо в сети.
- Искать проекты - используются теги и галереи проектов
- Комментировать проекты
- Обмениваться сообщениями внутри сообщества Scratch
- Загружать проекты с сервера и запускать их на своем компьютере
- Видоизменять проекты
- Использовать фрагменты проектов (объекты), внутри новых проектов.

Иногда встречается формулировка - данная модель является продолжением или развитием модели - далее следует ссылка на предшествующую модель и имя её автора.

Изучение поведения и построение моделей более не ограничивается отдельным компьютером. Мы можем предложить свое произведение другим членам сообщества, и они смогут не только посмотреть, как работает модель, но и разобраться в том, как сложены кирпичики модели, смогут взять эти кирпичики и строительные блоки и построить из них свое собственное здание. На сайте http://scratch.mit.edu/ можно не только посмотреть готовые работы, но и скачать их код. После этого любой желающий может видоизменить связь блоков программы и построить свою собственную, опираясь на плечи своих коллег.

Как вступить в сообщество Scratch?

Далее все прозрачно - заполняете поля формы. Может случиться, что имя, под которым вы хотите зарегистрироваться, уже занято. Выберите себе новое уникальное имя для регистрации.

Что мы можем делать с проектами на сайте сообщества:

1. Посмотреть проект в действии – для этого надо просто подождать и проект прямо с сайта загрузится в такой форме, что вы сможете увидеть не только анимацию, но и участвовать в игре, управлять объектом при помощи мышки или специальных клавиш клавиатуры.
2. Пометить проект метками, чтобы потом его было легче найти. Например, мы можем добавить к проекту свои метки.
3. Скачать проект (возможность отмечена в правом верхнем углу)
Посмотреть проект может любой желающий. Скачать проект может только член сообщества. Если вы уже зарегистрировались, то после просьбы скачать проект появится предложение открыть проект в Scratch или сохранить проект на диск. Советуем завести себе отдельную папку для примеров чужих проектов и складывать их туда.

Как можно пополнить архивы сообщества Scratch своими проектами?

Мы сделали Scratch-проект СуперКодЛого и хотим загрузить его на сайт сообщества
http://scratch.mit.edu.
Сохраним проект у себя на машине и положим его на общий сайт сообщества Scratch. Необходимо дать название проекту, указать имя автора - участника сообщества,пароль участника и краткое описание проекта.

Если все прошло успешно, то появится сообщение, что проект успешно загружен на сайт.

Желаем успехов в освоении программы Scratch!


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Как добавить новый объект

Для того, чтобы вызвать новое существо – (новый объект) под рабочей областью расположены несколько кнопок с изображениями:
- Кисточка, чтобы нарисовать новый объект
- Папка, чтобы достать готовый объект из библиотеки
- Коробочка со знаком вопроса, откуда можно достать случайный объект.

Среда, на фоне которой происходит действие, является таким же импортируемым и
видоизменяемым объектом. Мы можем нарисовать фон, на котором происходит действие
или взять для этого фона картинку из коллекции, которая пришла к нам вместе со
средой Scratch.

Мы можем самостоятельно добавить к коллекциям фона свои рисунки или фотографии. Размер рисунков и фотографий для фона – 480 на 360.

Фон (рисунок или фотографию), который мы выбрали для нашего проекта, можно отредактировать в Графическом редакторе, нажав на кнопку Редактировать:

В окне графического редактора можно воспользоваться необходимыми инструментами и цветовой палитрой.

Героев нашего проекта мы можем также нарисовать в Графическом редакторе самостоятельно, нажав на кнопку Кисточка:

Нажатием на кнопку Папка мы открываем библиотеку изображений с героями (спрайтами):

Важно отметить, что папки с изображениями объектов мы можем создавать и пополнять самостоятельно.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Скрипты

Перейдем к ящичкам, в которых сложены кирпичики. Если мы посмотрим на содержимое ящичков, то увидим, что содержимое отличается не только цветом. Есть ящички, где большей частью лежат строительные блоки, которые можно объединять друг с другом. Это кирпичики для изменения внешнего вида объектов, управления звуками, перемещения объектов и рисования. Эти строительные кирпичики делятся на закрытые и самодостаточные, к которым ничего добавить нельзя и внутрь которых ничего нельзя добавить. Например:
Если край, оттолкнуться

Есть кирпичики, в которых можно изменять значения или вставлять в них значения.
Например: Идти(20), Установить размер 0%
Есть ящички с блоками, которые нельзя соединять с другими, но которые можно вставлять внутрь других строительных блоков. Это ящики, где лежат цифры и датчики.

Есть ящик Контроля с управляющими конструкциями, которые позволяют
организовывать повторения команд, ставить условия, при которых блоки команд начинают выполняться и условия, когда действие команд прекращается. Команды приобретают смысл, когда Вы объединяете их в последовательность.
Например:

И объект начинает двигаться.

Все команды применимы не только к подвижным объектам, но и фону! Т.е. мало того, что можно добавлять разные фотографии в качестве фона. Над этими фоновыми фотографиями можно совершать любые операции при помощи команд из фиолетового ящика.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

Внешность
Фиолетовый ящик

Все команды однозначны. Чаще всего употребляются команды «Изменить()» и
«Убрать графические эффекты». Переходы между слоями легче всего пояснить на
примере 2-х одинаковых спрайтов котенка. У одного из них покрасим глаза в голубой цвет.
Если мы теперь попросим одного из котят менять слой, то получится простая
мультипликация – котенок будет менять цвет глаз.

Команда | Назначение
Перейти к костюму() | Перейти к костюму (можно выбрать костюм героя)
Выбрать костюм() | По умолчанию объект одет в костюм кошки, но мы можем выбрать и другие костюмы из библиотеки, пользуясь командой Импорт.
Изменить значение костюма | Изменить значение костюма на одну или несколько единиц. Имеет смысл только тогда, когда у нас несколько «импортных» костюмов.
Сказать | Сказать фразу, которую мы можем записать в окошечке команды.
Думать | Думать – отличается от «говорить» только графическим оформлением фразы
Убрать графические эффекты | Очистить все графические эффекты. Если мы производили над объектом видоизменение, то в результате этой команды все они отменяются
Изменить() | Изменить (цвет, округлость, яркость) () – видоизменить объект по одному из перечисленных параметров на указанную величину.
Показаться | Показать объект – он становится видимым
Спрятаться | Спрятать объект - он становится невидимым
Перейти в верхний слой | Объект перемещается в первый слой
Перейти назад на () слоев | объект уходит на несколько слоев внутрь
Значение костюма | Возвращает значение костюма, который в данный момент одет на нашем исполнителе.


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Что такое Scratch

Scratch (Скретч) - это новая среда программирования, которая позволяет детям создавать собственные анимированные интерактивные истории, игры и модели. Этими произведениями можно обмениваться с сообществом авторов Scratch-проектов по всему миру. В Scratch можно играть с различными объектами, видоизменять их вид, перемещать их по экрану, устанавливать формы взаимодействия между объектами. Это объектно-ориентированная среда, в которой блоки программ собираются из разноцветных кирпичиков команд.

В названии языка скрываются ссылки к нескольким метафорам:
1. Scratch ─ Царапина, скрип, перо, каракуля, старт
2. Old Scratch – (шутл.) – Сатана, дьявол
3. Scratch-cat – злючка
4. Scratch paper – черновик
5. To start from the Scratch – начинать с нуля, на пустом месте
Мы можем начинать пользоваться языком с нуля, не обладая никакими
предварительными знаниями о программировании.

Разработчики языка думают о том, как дети в среде Scratch смогут самостоятельно осваивать современную культуру, играть с образами, звуками, мультипликацией. В этой среде ученики не используют готовые компьютерные игры, а конструируют свои собственные игры, истории и модели. В ходе этой созидательной деятельности у учеников формируется свобода обращения с различными элементами окружающей медиакультуры.

В Scratch используется метафора кирпичиков Лего, из которых даже самые маленькие дети могут собрать простейшие конструкции. Дети могут собирать свои программы-процедуры из блоков так же, как они собирали конструкции из разноцветных кирпичиков. Из конструкций и управляющих структур могут быть собраны различные агенты, выполняющие простые инструкции. Эти агенты могут взаимодействовать между собой и воссоздавать сообщество в среде Scratch. В результате выполнения простых команд может складываться сложная модель, в которой будут взаимодействовать множество объектов, наделенных различными свойствами. Начальный уровень программирования столь прост и доступен, что Scratch рассматривается в качестве средства обучения не только старших, но и младших школьников.

Когда ученики создают проекты в Scratch,
они осваивают множество навыков XXI века:
• творческое мышление,
• предметное общение,
• системный анализ,
• беглое использование технологий,
• эффективное взаимодействие,
• проектирование,
• постоянное обучение


в среде Scratch

Что такое Scratch

Знакомимся с интерфейсом
программы

Как добавить новый объект

Скрипты

Содержимое ящиков

Первые шаги

Сообщество Scratch

Содержимое ящиков

Звук
Лиловый ящик

Лиловый ящик Скретч предоставляет массу звуковых возможностей. При этом звук можно выбрать в библиотеке – там этих звуков достаточно много. Так же как и библиотека картинок, библиотека звуков расширяется и к ней можно добавлять свои звуки в формате wav. Звуки можно записывать в редакторе самой среды Скретч. Внутрь звуковых кирпичиков можно добавить любые значения, которые мы вычисляем или считываем с датчиков. К разным объектам в Скретче можно добавлять свои музыкальные партии.

Команда | Назначение
Играть звук | Воспроизвести звук (можно выбрать звук). При этом звук никак не влияет другие действия нашего объекта
Играть звук до завершения | Играть звук до его завершения. Никакие другие действия наш спрайт при этом не совершает.
Выбрать инструмент | Выбрать инструмент, который будет играть. Инструментов в Скретче более 130
Барабанам | Ударные играют указанное число тактов
Играть ноту | Играть определенную ноту указанное количество времени (в секундах). Ноты записаны в цифрах, но против каждой цифры стоит ее звучание.
Убрать все звуки | Все звуки данной модели умолкают
Изменить темп | Меняет темп игры
Темп | Возвращает значение темпа игры